CARA CEPAT MENAMBAH RULE MANGLE DAN QUEUE PADA MIKROTIK DENGAN SCRIPT

Assalamu’alaikum wr.wb

cover 

Pada kesempatan kali ini saya akan coba membuat rule mangle, queue tree otomatis atau cepat  dengan script mikrotik. Otomatis dalam arti kita membuat firewall mangle dan queue tree semua IP Address yang terdapat dalam jaringan kita.

Disini contoh kasus: Saya ingin melimit bandwith per pc untuk memisahkan IIX dengan IX dengan
IP: 192.168.8.1 – 192.168.8.254

Yang pertama harus dibuat rule manglenya dulu dong, baru queque tree nya, belum lagi dirule manglenya itu ada mark paket, dan mark connection, bisa berapa hari kelar tuh kalau namabahin rule mangle dan queue satu persatu ?

Maka dari itu, digunakanlah script untuk menyelesaikan masalah tersebut

Untuk lebih mudahnya, bisa langsung diremote dari winbox atau putty

Yang pertama adalah script untuk connection mark untuk IIX

:for x from=1 to=254 do={ /ip firewall mangle add action=mark-connection chain=forward comment=”Komp 192.168.8.$x” disabled=no dst-address-list=nice new-connection-mark=”192.168.8.$x-IIX” passthrough=yes src-address=”192.168.8.$x” }

Sedikit penjelasan
:for x from=1 to=254 artinya adalah range ip yang akan saya gunakan

ip firewall mangle add action=mark-connection chain=forward artinya  kita menambahkan rule baru dengan chain: forward, dan action: mark-connection

dst-address-list=nice new-connection-mark=”192.168.8.$x-IIX” passthrough=yes src-address=”192.168.8.$x”
artinya dst-address-list menggunakan nice , nama connection mark: 192.168.8.$x-IIX , $x itu berarti range yang tadi kita buat yaitu angka 1-254 , maka nanti hasilnya adalah 192.168.8.(1-254)-IIX. dan src-address juga ip address dari 1-254.

Kemudian copy kan script tersebut pada terminal winbox atau putty
Screenshot_1

Bisa dilihat pada winbox, ip > firewall > mangle
Screenshot_1b

Selanjutnya kita buat mark connection untuk IX

Script untuk IX

:for x from=1 to=254 do={ /ip firewall mangle add action=mark-connection chain=forward disabled=no dst-address-list=!nice new-connection-mark=”192.168.8.$x-INTL” passthrough=yes src-address=”192.168.8.$x” }

Kemudian jalankan script pada putty atau winbox terminal
Screenshot_3

Kemudian dilihat hasilnya
Screenshot_3b
Agar terlihat berurut atau rapih, bisa diklik Src.Address

Connection mark untuk IIX dan IX sudah, sekarang kita buat untuk mark paket untuk IIX dan IX

Script mark paket untuk IIX

:for x from=1 to=254 do={ /ip firewall mangle add action=mark-packet chain=forward connection- mark=”192.168.8.$x-IIX” disabled=no new-packet-mark=”paket-iix-192.168.8.$x” passthrough=no src- address=”192.168.8.$x” }

Dan Script untuk IX

:for x from=1 to=254 do={ /ip firewall mangle add action=mark-packet chain=forward connection-mark=”192.168.8.1-INTL” disabled=no new-packet-mark=”paket-intl-192.168.8.$x” passthrough=no src-address=”192.168.8.$x” }

Screenshot_4

Dan bisa dilihat hasilnya
Screenshot_4b
Tuh cepetkan untuk membuat mark connection dan mark paket, kalau bikinnya satu satu mah. nope

Mark paket dan mark connection sudah, sekarang kita membuat queue treenya, dengan script juga tentunya

Tapi sebelum itu, kita buat dulu parent queue tree yang dibutuhkan, seperti ini nih
Screenshot_5

Selanjutnya kita lanjut ke script

Script untuk queue tree parent Download IX (Internasional)

:for x  from=1 to=254 do={/queue tree add burst-limit=0 burst-threshold=0 burst-time=0s limit-at=0 max-limit=0 name=”192.168.8.$x Download-INTL” packet-mark=”paket-intl-192.168.0.$x” parent=1.A-Download-Internasional priority=8 queue=default }

Script untuk queue tree parent Download IIX

:for x  from=1 to=254 do={/queue tree add burst-limit=0 burst-threshold=0 burst-time=0s limit-at=0 max-limit=0 name=”192.168.8.$x Download-IIX” packet-mark=”paket-iix-192.168.0.$x” parent=1.B-Download-IIX priority=8 queue=default }

Sedikit penjelasan:
{/queue tree add . . . name=”192.168.8.$x Download-INTL” artinya kita akan membuat queue tree dengan nama 192.168.8.(1-254) Download-INTL.

packet-mark=”paket-intl-192.168.8.$x” artinya dengan paket mark paket-intl-192.168.8.(1-254)

parent=1.A-Download-Internasional artinya yaitu dengan nama parent yang kita buat sebelumnya

Jalankan script tersebut
Screenshot_6

Kemudian bisa dilihat hasilnya pada queue tree
Screenshot_7 Screenshot_7b

Selanjutnya kita buat queue untuk Upload IX dan IIX

Script untuk Upload IX

:for x from=1 to=254 do={/queue tree add burst-limit=0 burst-threshold=0 burst-time=0s limit-at=0 max-limit=0 name=”192.168.8.$x Upload-INTL” packet-mark=”paket-intl-192.168.0.$x” parent=2.A-Upload-Internasional priority=8 queue=default }

Script untuk Upload IIX

:for x from=1 to=254 do={/queue tree add burst-limit=0 burst-threshold=0 burst-time=0s limit-at=0 max-limit=0 name=”192.168.8.$x Upload-IIX” packet-mark=”paket-iix-192.168.0.$x” parent=2.B-Upload-IIX priority=8 queue=default }

Seperti ini
Screenshot_8

Dann bisa dilihat hasilnya
Screenshot_9 Screenshot_9b

Mudah nan cepat bukan, sekian dari saya semoga bermanfaat😀

Wassalamu’alaikum wr.wb


Source: CARA CEPAT MENAMBAH RULE MANGLE DAN QUEUE PADA MIKROTIK DENGAN SCRIPT

Leave a Reply

Alamat email Anda tidak akan dipublikasikan. Ruas yang wajib ditandai *